Table of Content

I show how to install ionCube on PHP 5.6 but in other case there is no difference and only version of PHP should be changed in command.

Install required PHP version without -debug mode, ionCube does not support it

$ phpbrew install php-5.6.40 +default +mysql +pdo +fpm +gd +gettext +iconv +intl -debug -openssl

Use needable PHP version

$ phpbrew use php-5.6.40

Check your php version with php -v

$ php -v
PHP 5.6.40 (cli) (built: Jun  6 2019 16:09:30)
Copyright (c) 1997-2016 The PHP Group
Zend Engine v2.6.0, Copyright (c) 1998-2016 Zend Technologies

Download archive with ionCube extensions.
Unpack file _ioncube_loader_lin5.6.so to /home/popov/.phpbrew/php/php-5.6.40/lib/php/extensions/no-debug-non-zts-20131226. Pay attension to files with ts at the end (Thread Safety mode).

Create file 00_ioncube.ini under /home/popov/.phpbrew/php/php-5.6.40/var/db with next content

$ cat /home/popov/.phpbrew/php/php-5.6.40/var/db/00_ioncube.ini
zend_extension=ioncube_loader_lin_5.6.so

Run php -v, you should see that ionCube is enabled

$ php -v
PHP 5.6.40 (cli) (built: Jun  6 2019 16:09:30) 
Copyright (c) 1997-2016 The PHP Group
Zend Engine v2.6.0, Copyright (c) 1998-2016 Zend Technologies
    with the ionCube PHP Loader + ionCube24 v10.3.5, Copyright (c) 2002-2019, by ionCube Ltd.

If you use fpm run phpbrew fpm restart.

Last modified: 12.07.2019

Author

Comments

Write a Reply or Comment

Your email address will not be published.